Load Balancing 2 Line Speedy Office Best Performance - Find4Something

Load Balancing 2 Line Speedy Office Best Performance

Berikut adalah script lengkap untuk Mikrotik untuk menggabungkan / keseimbangan beban dua baris DSL . Dalam contoh ini saya menggunakan MikrotikT RB750 5 port router .
2 port yang terhubung dengan dua Router perbedaan DSL ,dan port 3 dihubungkan dengan Pengguna LAN .Kedua DSL kecepatan yang sama , masing-masing i.e 10Mb .
DSL MODEM IP 'SDSL MODEM 1 = 192.168.1.1DSL MODEM 2 = 192.168.2.1
Juga jangan lupa untuk mengubah nama nama antarmuka yang sesuai .
Dalam pengalaman personil saya , Jika pengguna meminta secara langsung memukul Mikrotik dikonfigurasi dengan PCC , maka Anda akan mendapatkan yang baik load balancing . Gunakan src -address sebagai classifier , cara ini Anda akan menyingkirkan masalah seperti https / broken link , masalah Streaming dll Load balancing menggunakan teknik PCC ini ( src -address ) akan efektif dan seimbang pendekatan ketika semakin banyak koneksi ( dari klien ) yang terjadi . Saya juga merekomendasikan untuk menggunakan server proxy yang SQUID bersama dengan mikrotik , baik paralel atau di depan atau backend , untuk waktu respon yang lebih baik dan juga akan meningkatkan pengalaman browsing yang baik untuk pengguna .
Jika entah bagaimana Anda tidak puas dengan pendekatan src -address , bermain dengan PCC - Classifier , maka Cobalah kedua alamat dan port sebagai classifier . Meskipun hal ini akan mengacak hal-hal yang paling dan dalam teori memberikan alokasi yang paling adil dari bandwidth, tapi ada juga kesempatan baik bahwa itu akan merusak hal-hal tertentu seperti situs web perbankan dan beberapa forum . Hal ini karena permintaan sering kali HTTP akan menghasilkan beberapa sambungan , sehingga ada kemungkinan bahwa beberapa permintaan mungkin pergi keluar rute yang berbeda daripada yang awal , dan itu akan merusak situs web aman . Untuk alasan itu saya biasanya tetap dengan src -address untuk load balancing PCC .

/ip address
add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=Local
add address=192.168.1.2/24 network=192.168.1.0 broadcast=192.168.1.255 interface=WAN1
add address=192.168.2.2/24 network=192.168.2.0 broadcast=192.168.2.255 interface=WAN2
 
/ip dns set allow-remote-requests=yes cache-max-ttl=1w cache-size=5000KiB max-udp-packet-size=512 servers=221.132.112.8,8.8.8.8
 
/ip firewall mangle
add chain=input in-interface=WAN1 action=mark-connection new-connection-mark=WAN1_conn
add chain=input in-interface=WAN2 action=mark-connection new-connection-mark=WAN2_conn
 
add chain=output connection-mark=WAN1_conn action=mark-routing new-routing-mark=to_WAN1
add chain=output connection-mark=WAN2_conn action=mark-routing new-routing-mark=to_WAN2
 
add chain=prerouting dst-address=192.168.1.0/24 action=accept in-interface=Local
add chain=prerouting dst-address=192.168.2.0/24 action=accept in-interface=Local
 
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/0 action=mark-connection new-connection-mark=WAN1_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/1 action=mark-connection new-connection-mark=WAN2_conn passthrough=yes
 
add chain=prerouting connection-mark=WAN1_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN1
add chain=prerouting connection-mark=WAN2_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN2
 
/ip route
add dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=to_WAN1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=to_WAN2 check-gateway=ping
 
add dst-address=0.0.0.0/0 gateway=192.168.1.1 distance=1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.2.1 distance=2 check-gateway=ping
 
/ip firewall nat
add chain=srcnat out-interface=WAN1 action=masquerade
add chain=srcnat out-interface=WAN2 action=masquerade
Semua Selesai! Sekarang Uji link dengan menempatkan beban pengguna, semakin banyak pengguna beban Anda menaruh di atasnya, hasil beban Balance yang lebih baik Anda akan mendapatkan :)

Yang ini Rule Kalo menggunakan Hotspot :D

/ip firewall nat add action=accept chain=pre-hotspot disabled=no dst-address-type=!local hotspot=auth

Subscribe to receive free email updates:

1 Response to "Load Balancing 2 Line Speedy Office Best Performance"

  1. nice post bro,
    lama nd brkunjung, so lebeh rame noh ini bro pe blog, bleh stoh kase tips
    kalo berkenan kunjungi balik bro

    ReplyDelete